using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".{30,}?\K\.(?=.{30,})";
string input = @"this is a long sentence. it contains full stops. I want to match the full stop after the halfway point.
this sentence is shorter. it also contains full stops.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}