import Foundation
let pattern = #".{30,}?\K\.(?=.{30,})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
this is a long sentence. it contains full stops. I want to match the full stop after the halfway point.
this sentence is shorter. it also contains full stops.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)