re = /.{30,}?\K\.(?=.{30,})/
str = 'this is a long sentence. it contains full stops. I want to match the full stop after the halfway point.
this sentence is shorter. it also contains full stops.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end