#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*(?<text>.*?)\s*((?<format>\([^)]*\))*\s*)*$"
Local $sString = "Chào mừng tất cả các anh chị đến với chủ đề dinh dưỡng và các bệnh về mắt." & @CRLF & _
"Chủ đề trước chúng ta đã tìm hiểu về mắt, và chúng ta đã biết rất nhiều bệnh về mắt." & @CRLF & _
"(text: Chủ đề dinh dưỡng và các bệnh về mắt; font-size:87; " & @CRLF & _
"typetext: giới thiệu;img: mat.jpg; effect: fadein; size: 6; subtext: đôi mắt khỏe;)" & @CRLF & _
"" & @CRLF & _
"Sau đây chúng ta sẽ tìm hiểu một số bệnh cơ bản về mắt mà hiện nay xã hội đang tồn tại."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")