package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*(?<text>.*?)\s*((?<format>\([^)]*\))*\s*)*$`)
var str = `Chào mừng tất cả các anh chị đến với chủ đề dinh dưỡng và các bệnh về mắt.
Chủ đề trước chúng ta đã tìm hiểu về mắt, và chúng ta đã biết rất nhiều bệnh về mắt.
(text: Chủ đề dinh dưỡng và các bệnh về mắt; font-size:87;
typetext: giới thiệu;img: mat.jpg; effect: fadein; size: 6; subtext: đôi mắt khỏe;)
Sau đây chúng ta sẽ tìm hiểu một số bệnh cơ bản về mắt mà hiện nay xã hội đang tồn tại.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}