package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i:match that)`)
var str = `match this Match and that and this not working!
this match that, and this too MaTch ThAt would work for sure
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}