import re
regex = re.compile(r"(?i:match that)")
test_str = ("match this Match and that and this not working!\n"
"this match that, and this too MaTch ThAt would work for sure\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")