$re = '/(?i:match that)/';
$str = 'match this Match and that and this not working!
this match that, and this too MaTch ThAt would work for sure
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);