#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[A-Z].*)(?=.*[!@#$&*])(?=.*[a-z].*).*$"
Local $sString = "123q" & @CRLF & _
"123@" & @CRLF & _
"Qwe@1" & @CRLF & _
"Admin" & @CRLF & _
"admin" & @CRLF & _
"admin@1" & @CRLF & _
"Admin@"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")