$re = '/^(?=.*[A-Z].*)(?=.*[!@#$&*])(?=.*[a-z].*).*$/m';
$str = '123q
123@
Qwe@1
Admin
admin
admin@1
Admin@';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);