using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[ABCDEFGHJKLMNOPRSTUWXYZ]{3}[0-9]{2}[ABCDEFGHJKLMNPRSTUWXYZ0-9]{1}";
string input = @"ABC120
ABC12O
IBC123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}