re = /[ABCDEFGHJKLMNOPRSTUWXYZ]{3}[0-9]{2}[ABCDEFGHJKLMNPRSTUWXYZ0-9]{1}/m
str = 'ABC120
ABC12O
IBC123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end