package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[ABCDEFGHJKLMNOPRSTUWXYZ]{3}[0-9]{2}[ABCDEFGHJKLMNPRSTUWXYZ0-9]{1}`)
var str = `ABC120
ABC12O
IBC123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}