using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\s]+)\.(?:png|jpe?g|pdf)";
string input = @"정말최종.jpg 정말정말_최종_기말고사.png 나진짜마지막이야.pdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}