// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^\s]+)\.(?:png|jpe?g|pdf)").unwrap();
let string = "정말최종.jpg 정말정말_최종_기말고사.png 나진짜 마지막이야.pdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}