$re = '/([^\s]+)\.(?:png|jpe?g|pdf)/m';
$str = '정말최종.jpg 정말정말_최종_기말고사.png 나진짜마지막이야.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);