package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\s]+)\.(?:png|jpe?g|pdf)`)
var str = `정말최종.jpg 정말정말_최종_기말고사.png 나진짜마지막이야.pdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}