#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(<img(?!.*?alt=(['"]).*?\2)[^>]*)(>)"
Local $sString = "<html>" & @CRLF & _
"<body>" & @CRLF & _
"<img src="tos.jpg">" & @CRLF & _
"" & @CRLF & _
"<img src="hfgfg.jpg" alt="texter alternatif">" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")