re = /(<img(?!.*?alt=(['"]).*?\2)[^>]*)(>)/m
str = '<html>
<body>
<img src="tos.jpg">
<img src="hfgfg.jpg" alt="texter alternatif">
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end