#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\((?<area>[2-9][0-9]{2})\) (?<prefix>[2-9][0-9]{2})\-(?<suffix>[0-9]{4})"
Local $sString = "(888) 888-8554"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")