$re = '/\((?<area>[2-9][0-9]{2})\) (?<prefix>[2-9][0-9]{2})\-(?<suffix>[0-9]{4})/';
$str = '(888) 888-8554';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);