// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\((?<area>[2-9][0-9]{2})\) (?<prefix>[2-9][0-9]{2})\-(?<suffix>[0-9]{4})").unwrap();
let string = "(888) 888-8554";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}