re = /\((?<area>[2-9][0-9]{2})\) (?<prefix>[2-9][0-9]{2})\-(?<suffix>[0-9]{4})/
str = '(888) 888-8554'
# Print the match result
str.match(re) do |match|
puts match.to_s
end