using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[img\](https?://.*?\.(?:jpe?g|gif|png|bmp)(?:\?(?:[^[]++|\[(?!/img\]))*+)?)\[/img]";
string input = @"[img]https://somelink/2/3/pic.jpg[/img][img]https://somelink/2/3/pic.jpg[/img]
[img]https://somelink/2/3/pic.jpg?w=bla[/img]
[img]https://somelink/2/3/pic.jpg?w=bla&test[5]=abc[/img]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}