$re = '~\[img\](https?://.*?\.(?:jpe?g|gif|png|bmp)(?:\?(?:[^[]++|\[(?!/img\]))*+)?)\[/img]~m';
$str = '[img]https://somelink/2/3/pic.jpg[/img][img]https://somelink/2/3/pic.jpg[/img]
[img]https://somelink/2/3/pic.jpg?w=bla[/img]
[img]https://somelink/2/3/pic.jpg?w=bla&test[5]=abc[/img]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);