import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[img\\](https?://.*?\\.(?:jpe?g|gif|png|bmp)(?:\\?(?:[^[]++|\\[(?!/img\\]))*+)?)\\[/img]";
final String string = "[img]https://somelink/2/3/pic.jpg[/img][img]https://somelink/2/3/pic.jpg[/img]\n"
+ "[img]https://somelink/2/3/pic.jpg?w=bla[/img]\n"
+ "[img]https://somelink/2/3/pic.jpg?w=bla&test[5]=abc[/img]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}