re = /\[img\](https?:\/\/.*?\.(?:jpe?g|gif|png|bmp)(?:\?(?:[^[]++|\[(?!\/img\]))*+)?)\[\/img]/m
str = '[img]https://somelink/2/3/pic.jpg[/img][img]https://somelink/2/3/pic.jpg[/img]
[img]https://somelink/2/3/pic.jpg?w=bla[/img]
[img]https://somelink/2/3/pic.jpg?w=bla&test[5]=abc[/img]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end