using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"create view [.\s\S]+?[ |\s\S]as[ |\s\S]";
string input = @"create view `default`.`daily_operation_volume` ( 记录数量 )
as select * from test";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}