package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)create view [.\s\S]+?[ |\s\S]as[ |\s\S]`)
var str = `create view \`default\`.\`daily_operation_volume\` ( 记录数量 )
as select * from test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}