import re
regex = re.compile(r"create view [.\s\S]+?[ |\s\S]as[ |\s\S]", flags=re.MULTILINE)
test_str = ("create view `default`.`daily_operation_volume` ( 记录数量 ) \n"
"as select * from test")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")