$re = '/create view [.\s\S]+?[ |\s\S]as[ |\s\S]/m';
$str = 'create view `default`.`daily_operation_volume` ( 记录数量 )
as select * from test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);