#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^\\/]+(?=[\\/]?$)"
Local $sString = "a/b/c/" & @CRLF & _
"a/b/c" & @CRLF & _
"\a\b\c" & @CRLF & _
"\a\b\c\" & @CRLF & _
"a\b\c" & @CRLF & _
"a/b/../../a/b/c/" & @CRLF & _
"a/b/../../a/b/c" & @CRLF & _
"C:\Windows\system32\kernel32.dll" & @CRLF & _
"/etc/network/interfaces" & @CRLF & _
"C:\Windows\system32\" & @CRLF & _
"/var/log/apt/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")