const regex = new RegExp('[^\\\\/]+(?=[\\\\/]?$)', 'gm')
const str = `a/b/c/
a/b/c
\\a\\b\\c
\\a\\b\\c\\
a\\b\\c
a/b/../../a/b/c/
a/b/../../a/b/c
C:\\Windows\\system32\\kernel32.dll
/etc/network/interfaces
C:\\Windows\\system32\\
/var/log/apt/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}