re = /[^\\\/]+(?=[\\\/]?$)/m
str = 'a/b/c/
a/b/c
\\a\\b\\c
\\a\\b\\c\\
a\\b\\c
a/b/../../a/b/c/
a/b/../../a/b/c
C:\\Windows\\system32\\kernel32.dll
/etc/network/interfaces
C:\\Windows\\system32\\
/var/log/apt/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end