$re = '/[^\\\\/]+(?=[\\\\/]?$)/m';
$str = 'a/b/c/
a/b/c
\\a\\b\\c
\\a\\b\\c\\
a\\b\\c
a/b/../../a/b/c/
a/b/../../a/b/c
C:\\Windows\\system32\\kernel32.dll
/etc/network/interfaces
C:\\Windows\\system32\\
/var/log/apt/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);