import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bUse (?:Phone: (?P<phn_num>\\d{10})|landline: (?P<lndln_num>\\d{10}))";
final String string = "1. Use Phone: 1234567890 or you can also use Landline: 0012345678\n"
+ "2. Use Landline: 0012345678 or you can also use Phone: 1234567890";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}