const regex = new RegExp('\\bUse (?:Phone: (?P<phn_num>\\d{10})|landline: (?P<lndln_num>\\d{10}))', 'gmi')
const str = `1. Use Phone: 1234567890 or you can also use Landline: 0012345678
2. Use Landline: 0012345678 or you can also use Phone: 1234567890`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}