import re
regex = re.compile(r"\bUse (?:Phone: (?P<phn_num>\d{10})|landline: (?P<lndln_num>\d{10}))", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("1. Use Phone: 1234567890 or you can also use Landline: 0012345678\n"
"2. Use Landline: 0012345678 or you can also use Phone: 1234567890")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")