$re = '/\bUse (?:Phone: (?P<phn_num>\d{10})|landline: (?P<lndln_num>\d{10}))/mi';
$str = '1. Use Phone: 1234567890 or you can also use Landline: 0012345678
2. Use Landline: 0012345678 or you can also use Phone: 1234567890';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);