#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\d_]+.json"
Local $sString = "521wei.xin_2022_04_03_13_09_20.json" & @CRLF & _
"wechat.design_2022_04_02_15_13_13.json" & @CRLF & _
"wechat.org_2022_04_01_15_47_58.json" & @CRLF & _
"admin.wechat.com_2022_04_01_15_37_35.json" & @CRLF & _
"wechatapp.com_2022_04_01_16_38_38.json" & @CRLF & _
"api.weixin.qq.com_2022_04_01_15_55_38.json" & @CRLF & _
"wechatlegal.cn_2022_04_01_16_20_20.json"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")