package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\d_]+.json`)
var str = `521wei.xin_2022_04_03_13_09_20.json
wechat.design_2022_04_02_15_13_13.json
wechat.org_2022_04_01_15_47_58.json
admin.wechat.com_2022_04_01_15_37_35.json
wechatapp.com_2022_04_01_16_38_38.json
api.weixin.qq.com_2022_04_01_15_55_38.json
wechatlegal.cn_2022_04_01_16_20_20.json`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}