# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\d_]+.json"
test_str = ("521wei.xin_2022_04_03_13_09_20.json\n"
"wechat.design_2022_04_02_15_13_13.json\n"
"wechat.org_2022_04_01_15_47_58.json\n"
"admin.wechat.com_2022_04_01_15_37_35.json\n"
"wechatapp.com_2022_04_01_16_38_38.json\n"
"api.weixin.qq.com_2022_04_01_15_55_38.json\n"
"wechatlegal.cn_2022_04_01_16_20_20.json")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.