use strict;
my $str = '521wei.xin_2022_04_03_13_09_20.json
wechat.design_2022_04_02_15_13_13.json
wechat.org_2022_04_01_15_47_58.json
admin.wechat.com_2022_04_01_15_37_35.json
wechatapp.com_2022_04_01_16_38_38.json
api.weixin.qq.com_2022_04_01_15_55_38.json
wechatlegal.cn_2022_04_01_16_20_20.json';
my $regex = qr/[\d_]+.json/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}