# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<={{mul\|(?:(?!{{|}}).)*?)\b(\w+)\|(?=(?:(?!{{|}}).)*\b\1\b)//gm;t' <<< "{{mul|fr|en|fr}}
{{mul|fr|fr|en}}"