use strict;
my $str = '{{mul|fr|en|fr}}
{{mul|fr|fr|en}}';
my $regex = qr/(?<={{mul\|(?:(?!{{|}}).)*?)\b(\w+)\|(?=(?:(?!{{|}}).)*\b\1\b)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";