import re
regex = re.compile(r"(?<={{mul\|(?:(?!{{|}}).)*?)\b(\w+)\|(?=(?:(?!{{|}}).)*\b\1\b)", flags=re.MULTILINE)
test_str = ("{{mul|fr|en|fr}}\n"
"{{mul|fr|fr|en}}")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)