const regex = new RegExp('(?<={{mul\\|(?:(?!{{|}}).)*?)\\b(\\w+)\\|(?=(?:(?!{{|}}).)*\\b\\1\\b)', 'gm')
const str = `{{mul|fr|en|fr}}
{{mul|fr|fr|en}}`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);