use strict;
my $str = 'today john jack and joe go to the beach
today joe and john go to the beach
today jack and joe go to the beach';
my $regex = qr/today ((?:jack|joe|and| )*)john(?1)\bgo to the beach/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}