re = /today ((?:jack|joe|and| )*)john(?1)\bgo to the beach/
str = 'today john jack and joe go to the beach
today joe and john go to the beach
today jack and joe go to the beach'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end