// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"today ((?:jack|joe|and| )*)john(?1)\bgo to the beach").unwrap();
let string = "today john jack and joe go to the beach
today joe and john go to the beach
today jack and joe go to the beach";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}